AppStore Permissions - Manual edits to Provisioning and Deprovisioning Flows are not shown until a page refresh

Incident Report for Lumos

Resolved

This incident has been resolved. No data was lost or affected, as the issue was only cosmetic in the AppStore Permissions UI.
Posted May 27, 2026 - 23:46 UTC

Identified

We have identified the issue and fix will be released shortly.
Posted May 27, 2026 - 15:57 UTC

Update

Incident being downgraded to Minor - Manual Edits to AppStore Permissions Provisioning and Deprovisioning Flows are being saved, but the updates are not shown in the UI until a page refresh. The workaround is to refresh the page after making the changes.
Posted May 27, 2026 - 15:06 UTC

Update

We are continuing to investigate this issue.
Posted May 27, 2026 - 15:05 UTC

Investigating

Incident being downgraded to Minor - Manual Edits to AppStore Permissions Provisioning and Deprovisioning Flows are being saved, but the updates are not shown in the UI until a page refresh. The workaround is to refresh the page after making the changes.
Posted May 27, 2026 - 14:51 UTC
This incident affected: AppStore.