Slowness Across Application

Incident Report for Lumos

Resolved

Latency issues have been fully resolved.
Posted Jun 11, 2026 - 16:30 UTC

Identified

The team has identified an issue causing slower loading speeds across the Lumos platform. We're actively working to resolve and restore full functionality.
Posted Jun 11, 2026 - 15:53 UTC
This incident affected: Platform.