Missing Activity Log Events

Incident Report for Lumos

Resolved

This incident has been resolved. All Activity Log events are visible again, and new Activity Log events will be displayed without a delay.
Posted Apr 21, 2026 - 21:39 UTC

Monitoring

All events will be restored as the queue drains. The team will continue monitoring through a full resolution.
Posted Apr 21, 2026 - 17:57 UTC

Identified

Our engineers have identified the root cause - events have been queued but are delayed.
Posted Apr 21, 2026 - 17:49 UTC

Investigating

We are currently investigating an issue where Activity Log events are failing to display in the UI.
Posted Apr 21, 2026 - 17:42 UTC
This incident affected: Platform.