Delay in processing workflows

Incident Report for Lumos

Resolved

This issue is resolved. All workflows have resumed normal processing with no delays.
Posted May 08, 2026 - 22:00 UTC

Monitoring

We are seeing a delay in some workflows being processed. The issue has been addressed, and all workflows are resuming where they left off.
Posted May 08, 2026 - 21:40 UTC
This incident affected: AppStore, Access Reviews, and Lifecycle Management.